Adobe Acrobat Reader Required.

Adobe Acrobat is required to enter data into the Adoption Application from your computer or tablet.


MS-Edge, Google Chrome, Safari, and other browsers let you look at PDF files.  But they do not allow interactive programming.


Adobe Acrobat is needed.


Get it here for free: (Click on one)


For Windows Operating System


For IPad, IPhone and Mac


For Android


Scroll down for the Application download.







 








Adoption Application

Puppy Application (Must use Adobe Acrobat download it from Adobe, Apple App Store, or Google Play Store) (pdf)

Download